» Blender 2.60.2 Cycles
Updated 04:38 November 9th, 2011
18
(1752)  2,499

With CUDA.

Build on Ubuntu 11.10

Some info about Cycles:

http://wiki.blender.org/index.php/Dev:2.6/Source/Render/Cycles

  

Latest commits:

Commit by psy-fi: r41664
Correct syntax for static, since we invoke g++ as linker and we have to pass it to ld
Commit by psy-fi: r41661
Cycles now uses correct libs on MinGW
Commit by blendix: r41657
Cycles:
* Disable precompiled cuda binaries, always do at run time
* Change preview samples default to 10
* Hide volume panels since they don't do anything yet Commit by blendix: r41651 Cycles: svn merge -r41627:41650 ^/trunk/blender Commit by blendix: r41599 Cycles: procedural texture nodes reorganization. This will break existing files
using them, but rather do it now that I have the chance still. Highlights:

* Wood and Marble merged into a single Wave texture
* Clouds + Distorted Noise merged into new Noise node
* Blend renamed to Gradient
* Stucci removed, was mostly useful for old bump
* Noise removed, will come back later, didn't actually work yet
* Depth setting is now Detail socket, which accepts float values
* Scale socket instead of Size socket

http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Nodes/Textures

Commit by dingto: r41588
Cycles: Use new libs on win32/64. Make sure you update lib/windows or lib/win64.

Commit by blendix: r41554
Cycles: make cycles work with new camera sensor size.
Commit by blendix: r41534
Cycles: fix DNA alignment problem in last commit.
Commit by blendix: r41533
Cycles: add location/rotate/scale and XYZ mapping options for all texture nodes,
to reduce the amount of nodes needed to set up a simple texture.
These are currently editable in the texture tab, still need to make
them available in the node editor. Projection and color modification options will
be added later, they're not implemented yet but allocated alredy to avoid
version patches later.
Also an issue with the XYZ mapping is that when you set one to None, texture and
material draw mode doesn't draw the image texture well, OpenGL doesn't seem to
like the degenerate texture matrix?
Commit by blendix: r41532
Cycles: svn merge -r41467:41531 ^/trunk/blender
Commit by blendix: r41526
Cycles: always use static bvh for non-viewport render. 
18 Comments so far. Leave yours.
22:00 April 14th, 2012
I just downloaded this build and I have to agree with Ultratron. This won´t work with Ubuntu 11.10 ... I get the error message:

gus@gus-Precision-WorkStation-T5400:~/Downloads/blender26$ ./blender
./blender: error while loading shared libraries: libspnav.so.0: cannot open shared object file: No such file or directory

I will try googling for an answer.
15:24 November 8th, 2011
17 . Azrael (builder)
Ultratron, that's an old build. I'm pretty sure that now that is named "add shader".
10:38 November 8th, 2011
Azrael.No closure in the materials and low caustics.
watch the end of this film:
http://www.youtube.com/watch?feature=player_embedded&v=rbXHW6PGbUQ
16:43 November 7th, 2011
Hello Azrael, same problem for me on ubuntu11.10... Damn!
12:16 November 7th, 2011
14 . Azrael (builder)
All this problems are about missing dependencies. Try installing this:
sudo apt-get install libstdc++6 libstdc++6-4.6-dev
09:50 November 7th, 2011
i have this problem on ubuntu 11.04 : ./blender: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./blender)
02:19 November 7th, 2011
12 . Azrael (builder)
Not even work through CPU?? GPU surely doesn't works with that video card, but I think CPU should be fine...
19:31 November 6th, 2011
After installing all the python files listed below additional dependencies are needed for Ubuntu 11.10:

libilmbase6 1.0.1-3build2 (for LibHalf)
libopenjpeg2
libspnav-dev

I installed them using the Ubuntu Software Center, but using "apt-get install" in a terminal might work too.

However Cycles builds, including this one (41547), crash when I try to render, giving the following terminal output:

Illegal instruction

Perhaps my Dell Latitude D510 with Intel graphics is not yet supported.
03:36 November 6th, 2011
10 . Azrael (builder)
Try installing this things:
sudo apt-get install libpython3.2 python3.2 python3.2-minimal python3.2-dev

It should work after that...
20:03 November 5th, 2011
Having the same problem as Kabal on Ubuntu 11.10 even after installing Python 3.2 as suggested.


...
Selecting previously deselected package python3.2.
Unpacking python3.2 (from .../python3.2_3.2.2-0ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Setting up python3.2-minimal (3.2.2-0ubuntu1) ...
Setting up python3.2 (3.2.2-0ubuntu1) ...
tm@Krishna:~/Desktop/blender26_cycles$ ./blender
./blender: error while loading shared libraries: libpython3.2mu.so.1.0: cannot open shared object file: No such file or directory
03:17 November 5th, 2011
8 . Azrael (builder)
Kabal, try installing python 3.2. Open a console and write sudo apt-get install python3.2
19:15 November 4th, 2011
bro, i used the terminal for running blender, and it shows me this error, please help


error while loading shared libraries: libpython3.2mu.so.1.0: cannot open shared object file: No such file or directory
carlos@carlos-P4M900-M7-FE:~$
18:13 November 4th, 2011
Comfirmed!, it doesn't work on Ubuntu 11.10, I don't know how to make that console thing, :C
04:51 November 3rd, 2011
Awesome, thanks for this build!
16:30 November 2nd, 2011
uv texture textures works well images are displayed correctly, as in the windows version of Azrael thank you for the great job:))
16:24 November 2nd, 2011
Good job works well:))
16:18 November 2nd, 2011
2 . Azrael (builder)
Ultratron, could you execute it through console and write here the error that gives to you? Let's try to get it works for you
15:57 November 2nd, 2011
does not work on Ubuntu 11.10 : (
Feeling talkative?
Log in to leave a comment.