» Trunk & Patches, Add-ons(contrib, external), Yafaray, LuxRender, All CUDA Archs
Updated 22:07 September 11th, 2012
91
(9691)  46,151

A Guide: for those who don't already know :)
Updating:
Luxrender, Yafaray Engines are compiled from source @ compile time
Luxrender, Yafaray, VRay Exporters are updated from source @ compile time
Contribution addons are updated @ compile time
External addons are updated @ every 2 weeks or as the auther update it @ BA.org or @ Blender Python
Addons list's on this page are updated @ ~every month
Notes:
-You can EXPAND the addons menus for more info on the addons included
-Built with Scons & MSVisualC++ SP1 & CUDA 4.2
-If you find a BUG in an addon, please report it to the addon's Auther.
-If you find a BUG in this build, please report it AFTER you make sure that it is specific to this build only.
-Sometimes things don't get compiled & the Last working one will be provided.
-If you press download and get a text file then simply open it and you'll have the Direct link to download,
that does happen as i upload on a better server when my upload rate goes low in the sink, so bear with me. :)
-If anyone needs a certain patch i'll TRY to add, just comment below :)
-For those who can't download the .exe file just Remove the .exe from file address and download.
Thanks: paula tejando, megasoft78, meta-androcto, crazycourier for their help, and all scripters for the wonderful scripts.

 

Whats new with the latest trunk:
-Many other minor updates
-harmoney phase 1 merged
-convext hull operator
-sculpt masking
-node groups enhancements
-skin modifier
-2D tracking
-outliner material drag and drop
-sequencer modifiers

Whats new with the latest patches:
Added:
-Occlusion Query Based Select
Updated:
-
Removed:
-

 

Whats new with the External addons:
changed repository log is from 551 to 558

 

With Libs:
OPENAL,FFMPEG, SNDFILE, LIBSAMPLERATE, SDL
ICONV, OPENEXR, CINEON, DDS, JPEG
REDCODE, OPENJPEG, PNG, TIFF, FFTW3
LCMS, ZLIB, LZMA, LZO, JACK (x86 only)
GAMEENGINE, BULLET, PLAYER, 3DMOUSE
FREETYPE, OPENMP, IK ITASC
PYTHON, PYTHON INSTALL, BUILDINFO, INSTALL
INTERNATIONAL, COLLADA
FMOD, MOD FLUID, DECIMATE, OCEANSIM
CYLCES, CUDA All Arch's, BOOST, OIIO

 

Optimizations:
RAYOPTIMIZATION

 

Release addons: click to expand

 

Contrib addons: click to expand

 

External addons: click to expand

 

Archived addons: click to expand
In case if ANYONE needs it

 

Patches:

 

Broken Patches: click to expand
and are here ONLY for reference
91 Comments so far. Leave yours.
10:51 October 9th, 2012
SMALLLUX problem.

-- This is not listed in the addons to enable. How do I get this working from this build? thanks
19:13 August 22nd, 2012
Welcome back, man! Great to see you're okay!
07:11 July 20th, 2012
bat3a, could You write the download link each time also at the top of description? It's easier couse it's just copy>paste&go rather than download>copy>paste>delete text file:)
04:56 July 20th, 2012
88 . bat3a (builder)
@kakachiex+@Joster101:i'll try next time if Allah wishes.
@uhtochki:that's numpy lib, i don't what the problem but it doesn't effect, i'll try to resolve it if Allah wishes.
03:24 July 19th, 2012
In blender user preferences > addons I have this: "Multiple addons using the same name found! Likely a problem with a script search path. (see console for details)" In console I have this: "fake module: addon missing 'bl_info' give bad performance"! : 'c:\\users\\name\\appdata\\roaming\\blender foundation\\blender\\2.63\\scripts\\addons\\name of addons\\_init_.py" I have big list addons with same warning.
09:29 July 14th, 2012
HI bat3a
Can you include the sketchfab export addon in your build? I think it would be quite useful.
you can found the link to this addon in the middle of this page http://www.sketchfab.com/faq
07:10 July 11th, 2012
can you add wireframe overlay from Nicholas Bishop very usefull for modeling here is the link and tahnks for your build my favorite....
http://codereview.appspot.com/6202058/
18:57 July 10th, 2012
84 . bat3a (builder)
@cooler_inc: that's is a whole branch, and as i said earlier "if i could do that i should be setting instead of ton :)".
22:09 July 4th, 2012
thx bat3a! broken presets already fixed http://projects.blender.org/tracker/?func=detail&atid=498&aid=32016&group_id=9
and I wonder, can you include this http://vimeo.com/45038904 in your future builds ?
08:27 July 4th, 2012
82 . bat3a (builder)
@Italic_: i just tested the scene and it renders OK!, i don't know how to help you, try re-downloading the file and rendering.
@cooler_inc: confirmed your error, but is it specific to my builds? it seems not, so it is a bug with blender, you can submit a bug report to blender.org.
23:28 June 29th, 2012
hi bat3a! found eeror when selecting presets in Movie Clip Editor->Tracking Settings
http://www.pasteall.org/pic/show.php?id=34060
22:22 June 27th, 2012
It was this scene specifically I had problems with: http://blenderartists.org/forum/showthread.php?239480-2.61-Cycles-render-benchmark
08:23 June 25th, 2012
79 . bat3a (builder)
@Italic_: can you post a scene i can test.
23:22 June 23rd, 2012
It seems the problem I was experiencing was not part of Cycles, but the compositing nodes. The render would finish, but wouldn't like the nodes. I found this out because the official build I downloaded (46461:46487M) rendered and composited just fine. Whether it's my fault, your fault, or Blender's fault, I don't know; but it's something I found out of the ordinary.
23:08 June 23rd, 2012
I also forgot to mention my computer specs. They are as follows:

Win7 x64 ult
AMD Phenom II x6 OCed to 3.72 GHz
Nvidia GTX 560 with 1 GB VRAM
8 GB of DDR3 RAM OCed to 1856 MHz
ATI Radeon HD 5870 eyefinity 6 with 2 GB VRAM
23:06 June 23rd, 2012
bat3a: I downloaded your build (48060) today, and couldn't get Cycles to finish any of my renders. It would start the render just fine, then when "finishing" it would crash Blender on any remotely complex scene. It would do it with both CPU and CUDA; I'm still trying to get it to compile my OpenCL kernels for my ATI card. A plain cube is just fine; it doesn't have any problems with that. As soon as I load one of my recent models or Mike Pan's BMW scene, it starts acting up. I'm going to try the official build next and see if it does it there, too. I'll let you know what happens with a follow-up comment here.
20:35 June 3rd, 2012
75 . bat3a (builder)
@zorglub:thanks for the test, keep it going :)
@LukeNukem: no idea, i don't have a dual card setup to test, but your welcome to submit a bug at blender.org
@mem: yeah me too, i was out of the internet, and the patches are giving me PAIN :(, campell is changing everything and i can't catchup.
19:46 June 3rd, 2012
Good to see you're back, man! Missed your builds around here.
02:34 May 18th, 2012
Thanks for the build. Blender crash with graphic card nvidia GTX690 (x2). Does there exist a solution to this ? Blender works with a single graphics card GTX690 (x1).
02:16 May 13th, 2012
I wanted to see how the different latest builds compare on my system W7 x64 i2600k not overclocked and GTX580

I first tried a BI rendering of a complex scene with many shadows and reflections :
1) r46561 by alb3530 : 16.80s
2) r46461 official 2.63a : 18.60s
3) r46534 by bat3a : 19.15s

Then tested the BMW1M Benchmark
1) r46534 by bat3a : 29.81s
2) r46561 by alb3530 : 35.28s
3) r46461 official 2.63a : 40.82s

Interesting results... and many thanks to all builders !
16:32 May 11th, 2012
71 . bat3a (builder)
@johnny: add v0.7.6 to my next build if Allah wishes.
@Regele IONESCU: as it seems that some have issues with skydrive, i changed it to the usual dropbox with this build :)
18:47 May 7th, 2012
Hi! I tried to download the last version but I am having problems with Skydrive. Not only is asking for an account but after I made the account I keep getting the following error: There's a temporary problem. There's a temporary problem with the service. Please try again. If you continue to get this message, try again later.

Has anyone managed to download the 64 bit version?
17:34 April 26th, 2012
I've got it to work together now: 3Delight/Blender 0.7.5 and your build 45820.
Cheers!
19:39 April 5th, 2012
I tried it (win64-44231 I think) but I only got preview render of material and plugin UI working. The very basic scene is rendered black. I didn't try plugin with other or older builds.
11:41 April 1st, 2012
67 . bat3a (builder)
@johnny: do you have a current one, tested it and it is not working!
@Saramary: please submit a bug @ blender tracker.
12:11 March 27th, 2012
Hello! I have a problem with bevel modifier: limit method "Weight" does not work. I can use Bevel from Specials (hotkey "W"), but in this case I can't change "Percentage" unit to my units (meters).
00:29 March 19th, 2012
Thanks for the build.
Is it possible to add 3Delight/Blender addon by Matt Ebb to this build?
(http://mattebb.com/3delightblender/)
07:13 March 10th, 2012
64 . bat3a (builder)
@JohnyBGooD: there is a bmesh face inset instead.
@Regele IONESCU: sorry i can't , i'm not a coder,a merely patcher builder :)
00:36 March 10th, 2012
Hello! First of all, thank you again for all your great builds! Secondly, there is a general problem(i.e. not related to your builds): in the output panel, under encoding, the bitrate, the maximum rate, the buffer, the rate, and the packet size are all limited to 14000. Could you remove that limit? For example I would like to be able to set the bitrate to 50,000 kbits/s. I found an workaround by setting all those values to zero I get maximum possible quality, but I would like to control to upper limit . Thank you again!
Regards,
Christian
02:44 February 28th, 2012
Inset Extrude addon was removed ? I cant found it in this build.
08:27 February 19th, 2012
61 . bat3a (builder)
@delta: you need to check the BAforums, i don't know how help you :(
@MmAaxx: true, but thats expeted as advanced array are modifiying things that the hain addon are using, so no solution!
@MadMinstrel &meta-androcto &MmAaxx: sorry my mistake, fixed it, re-download.
21:56 February 17th, 2012
Vray is disappered. :(
13:51 February 17th, 2012
hi, seems you built with the external addons still in 2.61 folder ;)
users can cut & paste to the right directory until fixed
12:09 February 17th, 2012
Something's wrong with the render addons - Blender says they're missing.
21:20 February 9th, 2012
advanced array modifier + chain addon, make blender crash :( works fine with normal array
11:31 January 28th, 2012
bat3a: thanks for that configuration path. I did it as You've suggested. Unfortunatelly nothing has changed:( Also now I have Nvidia Dev Drivers 286.16. The issue seems to be pure Cycles acces related but I can be wrong.
06:44 January 28th, 2012
55 . bat3a (builder)
@delta: if your using windows 7 go to C:\Users\*******\AppData\Roaming\Blender Foundation\Blender you'll find it there, back it up then delete it.
@cooler_inc: fixed now re-download.
01:47 January 27th, 2012
Hi, bat3a!
I get an error when running this build: CUDA error: Invalid value in cuMemcpyHtoD(mem, host, size)
Using GTX 560 ti with latest drivers, the previous build worked fine
Could u check pls)
11:14 January 26th, 2012
hmm...I have few Blender builds but found only in Megasoft's Yafaray latest build file called 'config'. This build is the only one where I can enter Ctrl+Alt+U and 'System' tab (and it's the old one as it hasn't Cycles included). Maybe it's different blender config file? So I still can't use fully blender with cycles (in linux there's no problem with it) I even tried to run Blender in Windows Safe Mode or with uninstalled Nvidia drivers still with same result. I don't know what else to do....reinstall Win7? Oh, and I have latest Cuda Toolkit 4.1, maybe this is the problem?

update: I've downloaded some old build 41599, run it and Cycles works perfectly CPU/GPU Cuda
08:37 January 26th, 2012
52 . bat3a (builder)
@delta: try deleting your config file after backing it up.
11:02 January 24th, 2012
update: I've uninstalled official Blender 2.61 x64 installation from blender.org fully via IObit Uninstaller/Revo Uninstaller just to make sure registry is also clean. After that custom builds from graphicall work again but: when I switch to cycles engine it crashes (all other engines work fine), when I click ctrl+alt+u and choose 'System' it crashes.
10:21 January 24th, 2012
@bat3a: still crashes (now every new build) and I've changed Blender's files to c:\blender\**whole blender files** so it's not the key.
btw I've installed theese things:

Microsoft Visual C++ 2005 Redistributable
Microsoft Visual C++ 2005 Redistributable (x64)
Microsoft Visual C++ 2008 ATL Update kb973924 - x64 9.0.30729.4148
Microsoft Visual C++ 2008 ATL Update kb973924 - x86 9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - KB2467174 - x64 9.0.30729.5570
Microsoft Visual C++ 2008 Redistributable - KB2467174 - x86 9.0.30729.5570
Microsoft Visual C++ 2008 Redistributable - x64 9.0.21022
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.17
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161
Microsoft Visual C++ 2008 Redistributable - x86 9.0.21022
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161
Microsoft Visual C++ 2010 x64 Redistributable - 10.0.40219
Microsoft Visual C++ 2010 x86 Redistributable - 10.0.30319

maybe something should be uninstalled or reinstalled?
07:09 January 17th, 2012
49 . bat3a (builder)
@AlexDS & delta: try changing the folder you extract to, try another system with same file.
06:21 January 14th, 2012
@bat3a: I've checked vc2008 runtime and SP1 also (both x64 as I have x64 win7) and everything is ok, however Blender crashes...also Blender Bullet build x64 has the same issue. Other x64 builds from graphicall work fine.
03:25 January 14th, 2012
your built cannot be pinned to the Windows 7 taskbar
any other build can be pinned with no problem...
21:44 January 13th, 2012
46 . bat3a (builder)
@delta: as for yafaray i'm trying to compile for a while, as for crashing check your vc2008 runtime
03:59 January 11th, 2012
btw this build 43260 x64 crashes, Blender won't start on my pc - first time since loooooong
15:43 January 10th, 2012
Hi Bat3a, could You add Yafaray but the new version with Irradiance Cashe and photon mapping GPU modes?
12:01 January 10th, 2012
43 . bat3a (builder)
@elieli: actually its something with the exporter, needs update to recent api changes, i contacted bdancer and still waiting for a fix.
04:28 January 10th, 2012
There is something wrong with v-ray exporter. It export strange mesh, and additional setting for V-ray. Updating exporer form bdancer's source changse nothing, I guess that it's comiled into Blender mesh exporter problem.
09:04 January 8th, 2012
41 . bat3a (builder)
@MmAaxx: sorry for the late answer but now is included.
@Herbert123: included.
14:00 January 5th, 2012
@Bat3a: The occlusion patch was updated for the current trunk. Please integrate it again in your build - thank you!
19:02 December 18th, 2011
your build are the best!
can you put inside also the GOZ for blender (link for zbrush directly)
here the link: http://www.zbrushcentral.com/showthread.php?127419-GoB-an-unofficial-GoZ-for-Blender/page3
07:57 December 15th, 2011
@bat3a

Awesome! Thank you so much!
23:18 December 14th, 2011
37 . bat3a (builder)
@kwayde: go to preference -> addons -> under the search box press on testing, and it will show (if Allah wishes) :)
21:49 December 14th, 2011
Hi bat3a,

I still can't seem to enable the luxrender engine or smallluxgpu. I don't have those options you listed for infernalvoice. I go to user preferences > add-ons > render > & then it lists cycles, light field tools, network renderer, POV, & renderfarm. Even when I use the search box for luxrender nothing seems to come up. Any advice?
01:57 December 9th, 2011
@Bat3a: Much obliged for including the occlusion select patch! Finally fast selection on ATI cards. Awesome - can't thank you enough.
21:21 December 8th, 2011
34 . bat3a (builder)
@holyenigma:sorry for the late answer, there is version 0.7 of this updated addon HERE:
http://bartoszstyperek.wordpress.com/2011/10/01/197/

it will be included in the next build, if Allah wishes.
17:14 December 8th, 2011
hwy Bat3a, This Mitsuba Exporter works.

http://bartoszstyperek.wordpress.com/2011/09/10/update-to-mitsuba-exporter-0-6/
00:47 December 8th, 2011
I found a working bat3a 40738 and Mitsuba will enable.. its 2.59

maybe something with 2.6 broke the script?
00:00 December 8th, 2011
Bat3a, i can't enable Mitsuba in the addon's, the check box will not click.. ??

it has been like this for awhile now.. not sure how far back it goes..
i was wanting to give mitsuba a try again,
but it dont work. :(

Any ideas?
13:06 December 6th, 2011
30 . bat3a (builder)
@infernalvoice: luxrender is included as python lib, just enable the addon -> render tab -> engine configuration -> export type -> internal, and smallluxgpu included too.
@Herbert123: i'll try to include in the next upload (if Allah wishes).
11:04 December 6th, 2011
Could you please add the occlusion select patch?

http://www.pasteall.org/27077/diff
11:00 December 6th, 2011
Hi,
i´m new to blender so i´m sorry if this question is stupid. I downloaded the blender build from within the text-file and think i get a blender build with luxrender. unfortunately there is no luxrender yet a yafaray render and i think it´s the v-ray exporter which is of no use for me cause of the lack of v-ray. do i make something false or what do i have to do to get luxrender going?
i hope somebody can help me out!
07:26 December 2nd, 2011
27 . bat3a (builder)
@Joster101:Neither do i, actually i'm happy that someone reports back show-stoppers, keep going, but only my build specific bugs :).
16:33 November 30th, 2011
@bat3a:sorry I didn't mean anything bad. Is there a better way or place to report these problem?
08:42 November 30th, 2011
25 . bat3a (builder)
@Joster101: it a bug in the trunk and NOT specific to my build, fixed now.
19:38 November 29th, 2011
Hi.
this build(rev42234)crash when I tried to create an empty.
07:16 November 18th, 2011
@bat3a: thanks for the quick update~
@Jerril:I think you can still download luxrender from their website to use external render.
02:51 November 18th, 2011
22 . bat3a (builder)
@Joster101: i confirmed the error, not specific to my build, it is specific to the revision, no i think it is fixed. re-download :)
@Jerril:ah... after recent merges the size got much bigger, and i had to remove it, and besides including two lux render engines is duplicating. another reason is i have a very bad upload speed and the extra 10mb make the build delay for 2 hrs :)
17:13 November 17th, 2011
External LuxRender render removed - any reason? That was very useful, internal render never ever works for me.
21:22 November 16th, 2011
Hi bat3a.
in this build I can't create any node in the node editor.
I tested other build and they work fine in my computer.
09:16 November 16th, 2011
19 . bat3a (builder)
@holyenigma: sorry for the late answer but i can't as i don't have it, i delete older version @ compile time :)
@stou: bmesh is a hole branch with lot's of mods to trunk, if i could that then i should be in place of ton :)
@MmAaxx: it is included in the archive folder if it's broken or it will be in the externals.
@Italic_: strange ! , i'm sure that i don't any viruses on my PC. can anyone confirm this?
@iisthphir: welcome to the free open source world.
@PhEnIX: cuda kernels should be generates on runtime, now it doesn't work, a fix is coming, you have to wait.
03:12 November 16th, 2011
Hi bat3a
I very like your builds but i have one question:
Why Cycles is only for openCL? I'm using Cuda so i can't rendering with graphical cart with your build.
If is possible to create one with using bouth.
Thanks PhEnIX
02:29 November 16th, 2011
Strange that i should have only blender crashing or unresponsive while using alpha/beta versions for over a year, and now that theres stable release something that has never happened before: it actually caused windows to completely stop working, had to actually hit the power button!
mabe theres some conflicting patches, also theres multiple versions of same addons, and multiple versions of same purposed addons and some reasonably useless ones, no offence to anyone.
I like getting a build with lots of experimental stuff and new addons sometimes, but i think it's excessive to perhaps comprrmise stability for some kinda pointless additions.
I also think there should mabe be more communication with addon developers. alot of really small simple tools for similar things could become one, better more usefull addon that is more stable and also easier to enable/disable without cluttering everything.
that said, thakns for the build!
C ya
19:46 November 6th, 2011
Is there any particular reason I'm getting "Virus Download Blocked" messages when I go to download? I've gotten this message for the last couple months, but I've downloaded it before.
23:29 October 31st, 2011
Hi man!

Why dont you put the "chromoly vertexslide" in your builds by default, for me it works better and works also with bmsh builds :D
04:35 October 26th, 2011
Hello. Any plans about adding bmesh ? Cheers.
04:20 October 23rd, 2011
looks like he fixed the material library crash :)
21:56 October 22nd, 2011
Bat3a, since 2.60 changed somethings and broke some stuff (like animation pose library for one)

could you post a link to the most recent 2.59(or tell us the revision of most resent one you posted before the merge)

(i have both "installed" unzipped, it would be nice if blender 2.60 made a 2.60 temp folder as well..
i could see that causing problems maybe later, in the "Blender Foundation" folder you can have 2.5 and 2.6 folder
if you have both installed, since they are different, give it a new folder.
these temp folders dont take up much space they just hold a couple text files)
00:52 October 18th, 2011
11 . bat3a (builder)
@kolab: Vectex plugin is dead for along time now, you can check its BA thread and see if the developer are willing to update.
@Joster101: check the broken addons section you can download it from there.
@Joster101: well my friend, the broken addons in the build doesn't harm and maybe in use for some devs or newbie's, actually my aim with this build is not to be a perfect, but too add the most options in one build.
06:56 October 17th, 2011
Hi bat3a.
I think you could remove a few addons from you build.
because I found some of them are not that useful now.
The ones I can think about now are the fast loop and select by type in sequencer.
the former is just ctrl + r (and we even have a button for that already called loopcut and slide)and the latter could be replaced now that we have select group(shift + g)in the sequencer.
I appreciate all these addons and their developers. but I'm afraid this build would become too bloated.
09:42 October 11th, 2011
Hi! bat3a. I can't find the UV helper Addon in your recent build.
I even check the script folder and it's not there?
any help on this?
08:03 October 6th, 2011
Hey. Could you add vectex plugin ?
18:32 October 2nd, 2011
Thanks for the answer, ill look forward to the new patches if the owner allows their usage
I'm sorry to hear that about Vectex, its a real shame, I liked that plugin.
@marksism Also I tried shift selecting several objects from the outliner and it worked in the current version and an older one I had around.
Maybe you had some conflicting script, or perhaps just an old Startup.blend that somehow messed up keymaps with newer versions.
17:33 October 2nd, 2011
6 . bat3a (builder)
@duarte.framos: Vectex plugin is dead for along time now, you can check its BA thread and see if the developer are willing to update.
@duarte.framos: ill try to add in the next build. - if Allah wishes
@marksism: i tested selecting with shift+LMB and it works OK
06:21 October 2nd, 2011
Thanks for the build. I'd been having problems with all the 2.59 builds I've tried so far- multi-selecting from the Outliner with Shift LMB wasn't working (a big problem in busy scenes) but all is as it should be with this build. Thanks for all your your work, it's highly appreciated.
07:34 September 30th, 2011
Sorry for double post, but I was browsing the old graphicall.org and stumbled this build http://www.graphicall.org/builds/builds/showbuild.php?action=show&id=1907
wich has some useful addons.
Would you be able to add this one : Tiles Texture http://blenderartists.org/forum/showthread.php?94666-Tiles-Texture
07:28 September 30th, 2011
Thanks for the great builds, I always use these!
What happened to the Vectex plugin? It used to be listed in the "NOT Implemented (and are here ONLY for reference)", was hoping you would get that patched up, but now its gone.
09:23 September 26th, 2011
2 . bat3a (builder)
@beta-tester: i don't know, it seems that it is deleted?!!
05:57 September 26th, 2011
@bat3e: what is happen with your old original link "http://www.graphicall.org/76" for that build? is it permanently gone after the GraphicAll problems/crash/hacker attack last weekend?
Feeling talkative?
Log in to leave a comment.